PHP is among the most commonly used general-purpose scripting languages. It is quite popular because it is free software, which can be used to set up responsive websites like social networking websites, web stores or online learning websites instead of static HTML sites. A PHP module should be enabled on the server where a PHP website is hosted so that its code can be ‘decoded’. Because there are no license fees for such a module and the language itself offers limitless options for the Internet apps that you develop, there are hundreds of millions of PHP-driven websites. What is more, there are an immense number of PHP-based scripts, which you can use for your sites without needing to have any coding skills. As there are a couple of versions of PHP, you need to make certain that the exact same version that you used whilst creating your site is present on the web server too.

PHP 4, PHP 5 and PHP 7 Support in Shared Hosting

With our shared hosting services, you will be able to choose which PHP version will be enabled for your shared hosting account, since several versions are enabled on our servers. With only one click of the mouse, you will be able to switch between PHP 4, 5, 7 and anytime a new version is published in the future, we’ll add it to the Hepsia hosting Control Panel without removing the earlier versions. In this way, you will be able to host all the websites that you have set up throughout the years. In stark contrast with lots of other companies, we will not compel you to update such websites, because a script may be outdated, but this doesn’t automatically mean that it’s vulnerable since you may have done modifications to its source code to prevent security gaps. For the sake of your convenience, you will even be able to set a different PHP version for each individual site hosted in your hosting account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

If you have a site built with an earlier PHP version and you’ve poured time and energy into setting it up, patching security breaches and adding web content, you’ll need a hosting service that can support it, since the majority of web hosting companies nowadays offer support only for the latest PHP version and abandon the older versions. We, however, have decided to permit you to pick the exact version that your own websites need. Our semi-dedicated services support PHP 4, PHP 5 and PHP 7, so you will be able to run both newer and older scripts without losing any manual modifications or wasting time and effort struggling to make your websites compatible with the web hosting platform. You can change the version via the Hepsia hosting Control Panel and such an update will affect the whole account, but you’ll also be able to pick a different version for each individual website hosted in your account by using an .htaccess configuration file.